dominoExperts.com - Powered by Domino 8.5.2 Domino Accelerator Pack
- Take load off your Domino server
Lotus Triple Search DominoExperts + Blogs + R8 forum
dominoExperts.com -> Trouble shooter

 Subform from another database on the web?


Joacim BoivePost date: 2007-05-12 12:21

Is it possible? I can't get it to display...

Added the originating databases ReplicaID(with and without ":") to the ACL, as Manager, of the db that contains the SubForm.

Works in the Notes client, but nothing turns up on the web.

 

Is it possible at all?

 

 

/Jocke


Tomas NielsenPost date: 2007-05-12 13:09

Yes it works. I am using it here in the forum actually.

You should not have to mess with the ACL. But it is important that you make sure you have inserted the subform from the same server as the form using it. I have had some strange effects with this. The dialog shows icons from your workspace but it is hard to know which ones you should choose sometimes.

There is one big drawback; When you insert the subform the form is connected to the replica id of the database the subform is inserted from. That means that if you create a new copy you will have to go trough all the forms that have the subform on it and reinsert the subform with a pointer to the new database.

But I like the functionality, I get instant updates across a whole site.


Tomas NielsenPost date: 2007-05-13 10:23

Are you by any chance using Domino 8? I have had a bit of a wrestling match with the subforms this morning. When I double clicked the subform it opened on the development server(!)

I could not get it to point back to the right server. I solved it by rolling back a backup... (Scheduled backups are really nice)


Joacim BoivePost date: 2007-05-15 10:41

The problem turned out to be that if you include a subform, from another database, that in turn contain a subform it doesn't work.

It MAY be related that both subforms contain information in the JS Header tag. Haven't tested without.

Nothing from the included subform(s) will display on the web, but will show up in the Notes Client perfectly.... Sounds like the authorization part is'nt quite sorted.

 

Remove the included subfrom, from the subform you're including, and it works.

Err... Did anyone get that? =)

 

Anyway, problem solved!

Thanks!

 

/J




RSS feed
Subscribe to Forum

Share this page

Top posters
Tomas Nielsen212
Joacim Boive27
Fredrik Stöckel27
Danne14
Niklas Waller13
Kenneth Haggman11
Bryan Kuhn10
Daniel Lehtihet9
Jonas Israelsson8
dm997